The Brick-yard Homepage Brickwerks
Forum Home Forum Home > T3 Section > T3 Engine Upgrades
  New Posts New Posts RSS Feed - Subaru expert needed.
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Subaru expert needed.

 Post Reply Post Reply
Author
Message
Benji89 View Drop Down
Groupie
Groupie
Avatar

Joined: 09 Jan 12
Location: salisbury
Status: Offline
Points: 216
Post Options Post Options   Thanks (0) Thanks(0)   Quote Benji89 Quote  Post ReplyReply Direct Link To This Post Topic: Subaru expert needed.
    Posted: 11 Oct 13 at 19:33
Subaru ej20 n/a.

Just driving home from work and suddenly had the oil warning light and the battery warning light come on but dim ish and goes off while on Rickover. The fuel pump has started making a wining noise (more than usuall) and there is a eggy smell I presume coming from the battery's? It runs, drives and sounds fine. Battery's fine and there's plenty of oil. Error code comes up as 12 starter switch (cold start circuit) anyone have a clue what it is or how to sort it?
Back to Top
nick1973 View Drop Down
Yardie
Yardie
Avatar
click, click, BUY!

Joined: 06 Sep 11
Location: doncaster
Status: Offline
Points: 865
Post Options Post Options   Thanks (0) Thanks(0)   Quote nick1973 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Oct 13 at 19:50
Have you got a speed sensor fitted
Back to Top
Benji89 View Drop Down
Groupie
Groupie
Avatar

Joined: 09 Jan 12
Location: salisbury
Status: Offline
Points: 216
Post Options Post Options   Thanks (0) Thanks(0)   Quote Benji89 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Oct 13 at 19:56
Yes mate I have. I've had the conversion for over a year with no probs. bar the idle speed control valve sensor fault light but that doesn't cause any real issues.
Back to Top
easy-does-it View Drop Down
Groupie
Groupie


Joined: 24 Sep 12
Location: under the bus
Status: Offline
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote easy-does-it Quote  Post ReplyReply Direct Link To This Post Posted: 11 Oct 13 at 20:24
 Check the thin wire ( was blue on my ej20t) on the starter motor (push on connector), think that was to do with cold start.. 
.76 Baywindow ..was EJ20T , now going superfly Tdi
Back to Top
Benji89 View Drop Down
Groupie
Groupie
Avatar

Joined: 09 Jan 12
Location: salisbury
Status: Offline
Points: 216
Post Options Post Options   Thanks (0) Thanks(0)   Quote Benji89 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Oct 13 at 20:44
I've pulled the wire off and looks alright. But alternator is makin a wining noise when I rev it. Would a dodgie alternator do it?
Back to Top
easy-does-it View Drop Down
Groupie
Groupie


Joined: 24 Sep 12
Location: under the bus
Status: Offline
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote easy-does-it Quote  Post ReplyReply Direct Link To This Post Posted: 11 Oct 13 at 21:12
 Typical dodgy alternator signs are dim flickering bat light, I'd get that checked first dude..
.76 Baywindow ..was EJ20T , now going superfly Tdi
Back to Top
nick1973 View Drop Down
Yardie
Yardie
Avatar
click, click, BUY!

Joined: 06 Sep 11
Location: doncaster
Status: Offline
Points: 865
Post Options Post Options   Thanks (0) Thanks(0)   Quote nick1973 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Oct 13 at 21:49
Eggy smell sounds like battery if you have amulti meter put it across the battery when it's running to check it charging ok and the alternator snot over charging
Pumps always wine
Back to Top
Benji89 View Drop Down
Groupie
Groupie
Avatar

Joined: 09 Jan 12
Location: salisbury
Status: Offline
Points: 216
Post Options Post Options   Thanks (0) Thanks(0)   Quote Benji89 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Oct 13 at 22:35
The pump is wining differently than usuall. As in a more high pitched wine. I'll get a metre onit tomorrow and see what it reads.
Back to Top
Allanw View Drop Down
Vanorak
Vanorak
Avatar
SYCOPHANTIC TRAINEE WELSHMAN

Joined: 21 Mar 10
Location: New Zealand
Status: Offline
Points: 1211
Post Options Post Options   Thanks (0) Thanks(0)   Quote Allanw Quote  Post ReplyReply Direct Link To This Post Posted: 12 Oct 13 at 10:30
The cold start wire/starter switch, is just a signal from the cranking circuit to the ECU - tells it you are cranking the engine to assist with starting. It is best hooked up.

It does sound like you have an alternator problem possibly.

Some of the earlier Hitachi alternators had dry joint issues which could cause some "interesting" electrical issues.
Allan :-)

'84 T3 Kombi, EJ25 DOHC, apprentice Viking...

Duct Tape can't fix stupid, but it can MUFFLE the sound.
Back to Top
Benji89 View Drop Down
Groupie
Groupie
Avatar

Joined: 09 Jan 12
Location: salisbury
Status: Offline
Points: 216
Post Options Post Options   Thanks (0) Thanks(0)   Quote Benji89 Quote  Post ReplyReply Direct Link To This Post Posted: 12 Oct 13 at 16:00
Got a metre on it this morning and it's reading 19.8 volts! New Alternater needed I think!! Another £110   
Back to Top
nick1973 View Drop Down
Yardie
Yardie
Avatar
click, click, BUY!

Joined: 06 Sep 11
Location: doncaster
Status: Offline
Points: 865
Post Options Post Options   Thanks (0) Thanks(0)   Quote nick1973 Quote  Post ReplyReply Direct Link To This Post Posted: 12 Oct 13 at 20:58
Get a second hand one there's loads about on eBay
Back to Top
Benji89 View Drop Down
Groupie
Groupie
Avatar

Joined: 09 Jan 12
Location: salisbury
Status: Offline
Points: 216
Post Options Post Options   Thanks (0) Thanks(0)   Quote Benji89 Quote  Post ReplyReply Direct Link To This Post Posted: 13 Oct 13 at 11:44
Only thing is buying off eBay is you don't know what your getting.
Back to Top
nick1973 View Drop Down
Yardie
Yardie
Avatar
click, click, BUY!

Joined: 06 Sep 11
Location: doncaster
Status: Offline
Points: 865
Post Options Post Options   Thanks (0) Thanks(0)   Quote nick1973 Quote  Post ReplyReply Direct Link To This Post Posted: 19 Oct 13 at 13:42
Just had a late 3 pin alternator rebuilt £45 if you can a local place
Back to Top
Benji89 View Drop Down
Groupie
Groupie
Avatar

Joined: 09 Jan 12
Location: salisbury
Status: Offline
Points: 216
Post Options Post Options   Thanks (0) Thanks(0)   Quote Benji89 Quote  Post ReplyReply Direct Link To This Post Posted: 19 Oct 13 at 14:10
Ah shit to late. Bought a new one at £144!!! Coulda bought a new subaru motor complete with wiring loom for £150, that the trouble when youqdont have any room!!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

The WebThis site