The Brick-yard Homepage Brickwerks
Forum Home Forum Home > T3 Section > Syncro
  New Posts New Posts RSS Feed - Engine Sub-Frame, Covers, etc
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Engine Sub-Frame, Covers, etc

 Post Reply Post Reply
Author
Message
madra View Drop Down
Yardie
Yardie
Avatar
Owns a T3 (and an LT)

Joined: 25 Jan 09
Location: mank-chester
Status: Offline
Points: 886
Post Options Post Options   Thanks (0) Thanks(0)   Quote madra Quote  Post ReplyReply Direct Link To This Post Topic: Engine Sub-Frame, Covers, etc
    Posted: 09 Jan 18 at 17:01
Looking through the manuals for my van , I'm starting to think that part of the sub-frame and/or engine covers may be missing. I can't get a piccie at the minute, as it's gone dark. But basically my engine seems to be bolted to two sub-frame beams running forward from the rear of the van to [i presume] a cross-member.

Unless I'm misunderstanding the diagrams in the manuals, it looks like there should also be a couple of sub-frame beams going transversally, left to right, across the van and [since BrickWerks sells insulation for the engine covers], I'm assuming there should be a couple of these as well. I've not got anything covering the engine underneath, at all.

If I am missing some engine covers, this might explain why the fecker sounds so noisy. Although I suspect the valve clearances might need checking too.

Anybody got a piccie or diagram showing what I should have under there?
1996 LT35 2,4D hi-top

My camper conversion blog: |carry on herman| <--not quite abandoned. But ever on the "ToDo" list!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

The WebThis site