The Brick-yard Homepage Brickwerks
Forum Home Forum Home > T5 Section > T5 Chat
  New Posts New Posts RSS Feed - Coil light flashing !!! Witts end
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Coil light flashing !!! Witts end

 Post Reply Post Reply Page  <123
Author
Message
Paul18765 View Drop Down
Not Quite Newbie
Not Quite Newbie
Avatar

Joined: 14 Jun 19
Location: Middlebrough
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paul18765 Quote  Post ReplyReply Direct Link To This Post Posted: 07 Jul 19 at 10:10
Thanks I will.
Back to Top
T5 surfer View Drop Down
Not Quite Newbie
Not Quite Newbie
Avatar

Joined: 08 Aug 18
Status: Offline
Points: 13
Post Options Post Options   Thanks (0) Thanks(0)   Quote T5 surfer Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 19 at 10:10
good point about the.  Egr
And i do believe the pump feeds the egr valve cooler also.
This is what came up on my faults first so i replaced the egr valve and had it coded in so thats all good hopefully.

Now i was thinking as you do...
So the fault only comes up during start up

So im im thing that when you switch off the pump is meant to come on to cool, now i think the fault is that the pump isnt kicking in,
So when i start the engine again it throws up the coil light as the pump didnt start on last start up.

Pump does work though if i use vagcom to switch it on

Another thing i have found is when using the torque app or car scanner pro app.

This is reading my coolant temp and its shockingly high
120 degC to 147 degC
But no warning lights on dash and no temp gauge either.

My mechanic asked which coolant sensor was ir reading but i had no idea.

So looks like the temp is high, the pump should cut in but isnt
The pump should cut in when i switch off but isnt 
And this maybe whats giving me the coil light.

I want to check the wiring from pump to the ecu but how do i gain access, i cant see much from underneath 🤔
Back to Top
T5 TDI View Drop Down
Vanorak
Vanorak
Avatar

Joined: 05 Nov 05
Status: Offline
Points: 3424
Post Options Post Options   Thanks (0) Thanks(0)   Quote T5 TDI Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 19 at 11:25
You could definitely do with being sure about the coolant temp sensor.  That won't be a genuine reading because the engine would be boiling but it could be that the coolant sensor is failing and sending the wrong value to the ECU.  However normally a value that high would cause a code.  The other possibility is that the scanners are mis-labelled and that reading is for another temp (exhaust gas maybe).  Although it seems odd if you have tried two different scanners.

You ought to get to the bottom of that before you go much further.  If you can find someone with genuine version of VCDS it would be easier, it is very reliable.  The sensor you are looking for is called the G62 coolant sensor.  There may be more than one.  
2004 2.5 174
Back to Top
 Post Reply Post Reply Page  <123
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

The WebThis site