The Brick-yard Homepage Brickwerks
Forum Home Forum Home > LT, Crafter & Sprinter Section > LT, Crafter & Sprinter Tech
  New Posts New Posts RSS Feed - carb trouble
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

carb trouble

 Post Reply Post Reply
Author
Message
axe wound View Drop Down
Not Quite Newbie
Not Quite Newbie


Joined: 22 May 09
Location: Leighton buzzar
Status: Offline
Points: 30
Post Options Post Options   Thanks (0) Thanks(0)   Quote axe wound Quote  Post ReplyReply Direct Link To This Post Topic: carb trouble
    Posted: 06 May 10 at 08:43
Just a quick thank you to all for the info.
The LT is running great now, if you dont remember I had carb trouble after fitting a Webber twin choke replacement carb.
The exhaust had blown to bits and i had a huge flat spot between first and second chokes on the carb.
Fix as follows ......

1.Test all compressions - all good.
2. trip to dyno - test showed up weak mixture on secondary stage idle jet, standard jet 80 replacement 100.
3. Test also showed up ignition advance sticky.
4. Strip down distributor clean and service all moving parts, this needed doing !.
5. Replace ignition leads with OE leads.
6.Drive van and adjust timing on the move.

The van runs real sweet , the only thing to do now is go back to the dyno and get them to check all settings and balance between HP and torque.

So thanks for all the good advice given as all the problems were covered between the postings.

Axe wound.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

The WebThis site