The Brick-yard Homepage Brickwerks
Forum Home Forum Home > LT, Crafter & Sprinter Section > LT, Crafter & Sprinter Tech
  New Posts New Posts RSS Feed - Battery Light Staying On?
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Battery Light Staying On?

 Post Reply Post Reply
Author
Message
volition82 View Drop Down
Yardie
Yardie
Avatar

Joined: 06 Jan 10
Location: somerset
Status: Offline
Points: 972
Post Options Post Options   Thanks (0) Thanks(0)   Quote volition82 Quote  Post ReplyReply Direct Link To This Post Topic: Battery Light Staying On?
    Posted: 21 Feb 13 at 10:30
From when I first bought my van the battery light has stayed on when you start it.  Once you rev it a bit the light goes out.  At first I thought it was perhaps the brushes sticking so I replaced them and no change.  The alternator packed up after a year or so and I bought a new one so I thought the problem would go away but no it still does it.  It's slightly worse if anything.
 
From reading various other threads it seems i'm not the only one with the problem but what causes it?  Is it the lead from the alternator to the battery?
1989 LT35 - 2.4 Lpg/Petrol - Converted To Camper
Back to Top
mat_the_cat View Drop Down
Vanorak
Vanorak
Avatar

Joined: 06 May 09
Location: North Wales
Status: Offline
Points: 1862
Post Options Post Options   Thanks (0) Thanks(0)   Quote mat_the_cat Quote  Post ReplyReply Direct Link To This Post Posted: 21 Feb 13 at 11:29
I suspect it's a feature rather than a fault - alternators require an excitation current to get them to start charging. This is normally from the battery via the ignition warning lamp. But, some alternators are designed with an internal circuit which only supplies an excitation current when it's rotating past a certain RPM. I'd only come across it on single wire alternators before though. Either way, my original alternator was like this, as was my brand new replacement. There is also no output to the rev counter from the W terminal until this RPM is reached (not applicable to petrols)

It's actually quite useful, as I've wired in a cut off in the LPG line from my tank which shuts off the gas once the batteries start charging - to prevent me from driving off with the gas still on! But if I've parked up and just want to shift the van a few feet, I can still do so without having to relight the fridge etc, so long as I don't rev the engine...
Mid engined, 6 cylinder, turbocharged 2 seater - it can only be a VW LT!
Back to Top
mrhutch View Drop Down
Moderator Group
Moderator Group
Avatar
the ginger princess

Joined: 21 Aug 07
Location: Herefordshire
Status: Offline
Points: 5098
Post Options Post Options   Thanks (0) Thanks(0)   Quote mrhutch Quote  Post ReplyReply Direct Link To This Post Posted: 21 Feb 13 at 12:43
WHS ^^  sounds like the exicter wire / system to me.  I replaced the alternator on the wifes a4 and this one does exactly the same thing.  No response from the exciter wire to the alt untill 2.5 revs..  I've never bothered to look more into it, or fix it..  She hits 3K coming out of the drive.
T3 1981 Westy Vanagon - thinks lubricant is a fuel
Back to Top
volition82 View Drop Down
Yardie
Yardie
Avatar

Joined: 06 Jan 10
Location: somerset
Status: Offline
Points: 972
Post Options Post Options   Thanks (0) Thanks(0)   Quote volition82 Quote  Post ReplyReply Direct Link To This Post Posted: 22 Feb 13 at 09:27

Thanks for that.  I've never had a vehicle do it before so I did think it was a fault and it was beginning to get on my nerves.  Good to know it's not.  I guess it's another quirk i'll have to learn to love like warp factor -300, being able to cycle faster up hills, seam rust etc etc LOL

1989 LT35 - 2.4 Lpg/Petrol - Converted To Camper
Back to Top
woodyrich1965 View Drop Down
Groupie
Groupie


Joined: 19 Sep 12
Location: devizes
Status: Offline
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote woodyrich1965 Quote  Post ReplyReply Direct Link To This Post Posted: 22 Feb 13 at 20:57
mine is the same ..cleaned mine up when i changed the cambelt and no differance so will just live with it
Back to Top
gary1998 View Drop Down
Yardie
Yardie
Avatar

Joined: 26 May 10
Location: dublin ireland
Status: Offline
Points: 463
Post Options Post Options   Thanks (0) Thanks(0)   Quote gary1998 Quote  Post ReplyReply Direct Link To This Post Posted: 23 Feb 13 at 00:20
same on my t3 also same on my b3 passat 
beware the fury of a patient man

http://www.eireball.com/
Back to Top
lorryloader View Drop Down
Yardie
Yardie
Avatar

Joined: 27 Sep 12
Location: ireland
Status: Offline
Points: 807
Post Options Post Options   Thanks (0) Thanks(0)   Quote lorryloader Quote  Post ReplyReply Direct Link To This Post Posted: 24 Apr 13 at 21:33
yup same prob 26 years ! just accepted it .
Back to Top
Chappy View Drop Down
Vanorak
Vanorak
Avatar
Arriba! Yii-hah!

Joined: 08 Jul 07
Location: North O'Cardiff
Status: Offline
Points: 4961
Post Options Post Options   Thanks (0) Thanks(0)   Quote Chappy Quote  Post ReplyReply Direct Link To This Post Posted: 24 Apr 13 at 22:51


Yep, same on our T3 and Florida Big smile



Back in the slow lane, yeah!
Back to Top
Canada LT28 View Drop Down
Vanorak
Vanorak
Avatar

Joined: 03 Jan 10
Location: Toronto
Status: Offline
Points: 1626
Post Options Post Options   Thanks (0) Thanks(0)   Quote Canada LT28 Quote  Post ReplyReply Direct Link To This Post Posted: 25 Apr 13 at 22:53
All the older diesels do it so there is less load on the engine till it heats up a bit. Been that way since the cows went out, far as I know.
94 LT28 Doka 2.4D
Slow and built to stay that way
87 T3 soon to be a camper
Back to Top
Monster LT View Drop Down
Groupie
Groupie
Avatar

Joined: 02 Jan 15
Status: Offline
Points: 169
Post Options Post Options   Thanks (0) Thanks(0)   Quote Monster LT Quote  Post ReplyReply Direct Link To This Post Posted: 04 Jan 18 at 20:10
Happy New Year all!
Old thread but i'm having the same problem with the battery light staying on when ignition is turned on. Rev counter doesn't work either until accelerator pedal is depressed and revs rise above 2000 or so, then battery warning light goes out and rev counter kicks in. (I've posted about this before)
A bit annoying but I can live with it... until now... when the light goes out and the rev counter kicks in I'm getting a high pitched metallic noise like a bearing about to fail. The sound quiets down after a few minutes but it's annoying and worrying. Alternator bearing? So I researched a bit and found a local alt and starter repair place who could supply bearings. When I went to purchase the bearings I told the worker about the problem and he said I'd better bring the unit in for a check as the battery warning light should go out when ignition is turned on. I told him the explanation for the light being on, like mat_the_cat gives above but he said that wasn't so and another customer agreed that shouldn't happen. So I took the van down for the guy to have a listen to the sound before pulling the alt out for testing.
He indeed heard the noise and couldn't say for sure what it was or why the light wouldn't go out without reving and said there was definitely a problem with the alt. So I pulled it out took it for a free check up and it passed the tests. Bearings seem OK. No noise. One observation was the W contact had gotten hot at some point - there was visible colour change to the metal but that's all. The W was producing 7.2V or so which was said to be good. The guy that tested it is around 70yoa and couldn't explain the issue I'm having with the light / rev counter and said the noise must be something else.
So is anyone else having the same problem with the rev counter. Anyone have an idea what the noise could be? Oh and has anyone "solved" this issue or do all these alternators function the same way? Is it designed like that as mat_the_cat and others said? I remember reading about alternators about them needing excitement before they start to put out a charge but the guys in the repair shop didn't seem to think so. They've been in business 25 years+ so who am I to argue?


Edited by Monster LT - 04 Jan 18 at 21:36
LT45-TD-ACL-intercooler-4x4-1993
Back to Top
Buss Marius View Drop Down
Groupie
Groupie
Avatar

Joined: 05 Jan 16
Location: Oslo Norway
Status: Offline
Points: 90
Post Options Post Options   Thanks (0) Thanks(0)   Quote Buss Marius Quote  Post ReplyReply Direct Link To This Post Posted: 04 Jan 18 at 22:20
In Our Company we have been doing wrong for 30 years and cal it experience....

The two T4 2,4D we had from 1991 and 93 where like this also, and yes the LT is not supposed to start charging before a certain rev are reached

Is it the fanbelt istelf?
87 Karmann LT L 2,4D. 89 T3 Syncro Reimo 1,9TD. 2000 T4 Caravelle TDI
Back to Top
Monster LT View Drop Down
Groupie
Groupie
Avatar

Joined: 02 Jan 15
Status: Offline
Points: 169
Post Options Post Options   Thanks (0) Thanks(0)   Quote Monster LT Quote  Post ReplyReply Direct Link To This Post Posted: 04 Jan 18 at 23:12
Ha ha... Ok, thanks Marius! I don't remember the light / rev counter issue when I first started driving this LT but after 6 mnths I spotted it along with a noisy alt belt which got changed and has been changed again since. Last time I replaced it was too tight to get the old one off so I got a slightly longer belt which fitted OK but has now stretched a bit too much so I'll make sure it's nice n tight when it goes back on or replace it yet again and see if the horrible noise stops.
LT45-TD-ACL-intercooler-4x4-1993
Back to Top
ottoMan View Drop Down
Groupie
Groupie
Avatar

Joined: 11 Sep 15
Location: Colchester UK
Status: Offline
Points: 41
Post Options Post Options   Thanks (0) Thanks(0)   Quote ottoMan Quote  Post ReplyReply Direct Link To This Post Posted: 07 Jan 18 at 07:49
Mine is the same and has always been like this - the battery light only goes off after a bit of revs. 2.0 petrol engine, so it's not only with diesels. The alternator works perfect and charges the batteries without problems. Never worried about that light and it never gave me reasons to worry.
1980 Pop Top LT28 2.0 Petrol converted by Karroseriefabrik Voll von Wurzburg
Back to Top
Monster LT View Drop Down
Groupie
Groupie
Avatar

Joined: 02 Jan 15
Status: Offline
Points: 169
Post Options Post Options   Thanks (0) Thanks(0)   Quote Monster LT Quote  Post ReplyReply Direct Link To This Post Posted: 08 Jan 18 at 13:14
I spoke to yet another ALTERNATOR REPAIRMAN! and he also thought my alternator had a problem when I explained about the light / rev counter / noise. So it seems the pro's don't have a clue about this in built function.  Also spoke to another forum member who said all 4 LT's he's had do the same thing. It does make sense for easier starting. I can hear the engine labour more when the alt starts charging.

After wedging the alternator back into it's spot and literally spending hours trying to wiggle it into the correct position to get the top bolt through, and this time using the original 10x800 sized belt, I turned on reved up and no horrible noise. Big smile


Edited by Monster LT - 08 Jan 18 at 13:19
LT45-TD-ACL-intercooler-4x4-1993
Back to Top
robbydoo View Drop Down
Yardie
Yardie


Joined: 08 May 06
Status: Offline
Points: 512
Post Options Post Options   Thanks (0) Thanks(0)   Quote robbydoo Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 18 at 17:49
Mine stays on until I rev it a bit also......once out all ok.....
1985 LT40 2.4TD Coach built Pioneer Diamond
Back to Top
Chappy View Drop Down
Vanorak
Vanorak
Avatar
Arriba! Yii-hah!

Joined: 08 Jul 07
Location: North O'Cardiff
Status: Offline
Points: 4961
Post Options Post Options   Thanks (0) Thanks(0)   Quote Chappy Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 18 at 21:53


Mine too. Always has-had it six years now...
Back in the slow lane, yeah!
Back to Top
Widar View Drop Down
Groupie
Groupie
Avatar

Joined: 29 Nov 13
Location: Sweden
Status: Offline
Points: 66
Post Options Post Options   Thanks (0) Thanks(0)   Quote Widar Quote  Post ReplyReply Direct Link To This Post Posted: 15 Jan 18 at 11:56
My 2.0 petrol -82 does the same.

Edited by Widar - 15 Jan 18 at 12:03
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

The WebThis site