The Brick-yard Homepage Brickwerks
Forum Home Forum Home > T4 Section. > T4 Chat
  New Posts New Posts RSS Feed - 2.4d Turbo probs... boost k14
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

2.4d Turbo probs... boost k14

 Post Reply Post Reply
Author
Message
tomschute View Drop Down
Yardie
Yardie
Avatar

Joined: 21 Nov 06
Location: Mid Wales
Status: Offline
Points: 287
Post Options Post Options   Thanks (0) Thanks(0)   Quote tomschute Quote  Post ReplyReply Direct Link To This Post Topic: 2.4d Turbo probs... boost k14
    Posted: 05 Mar 18 at 11:13
Hi Guys,

I have just installed a k14 turbo from the Volvo v70 onto my 2.4d. Same as this...


I was a little confused how to control boost as it has the internal actuator. 

But from what I can fathom the metal pipe clearly seen here boosts up and closes the waste gate. So I needed to put a MBC valve inline to blow off pressure to allow the waste gate to stay shut an amount.

Problem is it simply doesn't seem to build up much boost, around 0.4bar, even with the pipe completely disconnected, i.e. leaving waste gate totally closed. 

I've increased fueling half a turn so it's not that I don't think. And don't think I got a leak on the boost hoses.

I'm running boost gauge from the (volvo) inlet manifold.

Anyone got any ideas?

thanks,

Tom
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

The WebThis site